[Logo] SpagoWorld Forums
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing  
[Groups] Back to home page  [Moderation Log] Moderation Log   [Register] Register /  [Login] Login 
Problem with office document in spagobi 2.6 [SOLVED]  XML
Forum Index » Technical Help - SpagoBI Server - OFFICE
Author Message
algam.spw



Joined: 26/07/2010 14:24:22
Messages: 1
Offline

Hi,

I try the new spagobi version 2.6 and i can't use Office Document.
I try the demo on your website http://www.spagoworld.org/xwiki/bin/view/SpagoBI/ (Examples / Analytical Model / Office),
I try a demo version in windows environment,
I try a demo version in linux environment,
and nothing...

In SpagoBI.log i have the next error :
[http-8066-5] 30 juil. 2010 14:45:22,534 ERROR it.eng.spagobi.engines.officedocument.GetOfficeContentAction.service:118 - Exception
java.lang.NullPointerException
at it.eng.spagobi.services.content.service.ContentServiceImplSupplier.readTemplate(ContentServiceImplSupplier.java:86)
at it.eng.spagobi.engines.officedocument.GetOfficeContentAction.service(GetOfficeContentAction.java:8
at it.eng.spago.dispatching.action.ActionCoordinator.invokeServiceBusiness(ActionCoordinator.java:209)
at it.eng.spago.dispatching.action.ActionCoordinator.service(ActionCoordinator.java:15
at it.eng.spago.dispatching.httpchannel.AdapterHTTP.service(AdapterHTTP.java:433)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at it.eng.spagobi.commons.filters.ProfileFilter.doFilter(ProfileFilter.java:117)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at it.eng.spagobi.commons.filters.SpagoBICoreCheckSessionFilter.doFilter(SpagoBICoreCheckSessionFilter.java:107)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:12
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:286)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:845)
at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
at java.lang.Thread.run(Thread.java:619)

is somebody have the problem ?

Thanks for your help

This message was edited 2 times. Last update was at 27/09/2010 13:07:26

alexviennois.spw

Newby

Joined: 07/08/2010 14:41:49
Messages: 13
Offline

I have exactly the same problem, on two different installations.
The description of the logs seems to speak about a template problem, but they are correctly saved, and can be open without any problem.
alexviennois.spw

Newby

Joined: 07/08/2010 14:41:49
Messages: 13
Offline


Ok, the issue is fixed, I've found the solution in the SVN repository.

The problem is in the file:
webapps\SpagoBI\WEB-INF\classes\it\eng\spagobi\services\content\service\ContentServiceImplSupplier.class

To fix the problem, just download the last version of the file in the SVN repository, compile it and replace the file provided with the demo. It runs now.
aziz.spw

Newby

Joined: 12/07/2010 18:03:23
Messages: 30
Location: Paris, France
Offline

Hi,

I have the same problem, I want to know how to get the latest version from SVN and how to compile it.

Thanks for your help.

Aziz
 
Forum Index » Technical Help - SpagoBI Server - OFFICE
Go to:   
Powered by JForum 2.1.9 © JForum Team