[Logo] SpagoWorld Forums
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing  
[Groups] Back to home page  [Moderation Log] Moderation Log   [Register] Register /  [Login] Login 
Help for SpagoBI repository configuration [SOLVED]  XML
Forum Index » Technical Help - SpagoBI Server - CORE
Author Message
gorotman.spw

Newby

Joined: 10/01/2012 12:17:21
Messages: 21
Offline

Hi everybody, I'm sorry if this post may be a copy of others....but I searched, read and tried solution for hours....
I installed spago servers from single war in a new tomcat 7 installation, but I can't find a correct repository configuration.

My env is:
- windows server 2003 R2 (32bit)
- tomcat 7.0.25
- java 1.6.0.24
- sql server 2008 (remote)

this is my catalina.log:

24-gen-2012 15.43.06 org.apache.catalina.core.AprLifecycleListener init
INFO: Loaded APR based Apache Tomcat Native library 1.1.22.
24-gen-2012 15.43.06 org.apache.catalina.core.AprLifecycleListener init
INFO: APR capabilities: IPv6 [false], sendfile [true], accept filters [false], random [true].
24-gen-2012 15.43.07 org.apache.coyote.AbstractProtocol init
INFO: Initializing ProtocolHandler ["http-apr-8081"]
24-gen-2012 15.43.07 org.apache.coyote.AbstractProtocol init
INFO: Initializing ProtocolHandler ["ajp-apr-8010"]
24-gen-2012 15.43.07 org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 1398 ms
24-gen-2012 15.43.07 org.apache.catalina.core.StandardService startInternal
INFO: Starting service Catalina
24-gen-2012 15.43.07 org.apache.catalina.core.StandardEngine startInternal
INFO: Starting Servlet Engine: Apache Tomcat/7.0.25
24-gen-2012 15.43.07 org.apache.catalina.startup.HostConfig deployDescriptor
INFO: Deploying configuration descriptor E:\Applicativi\spago\apache-tomcat-7.0.25\conf\Catalina\localhost\SpagoBI.xml
24-gen-2012 15.43.07 org.apache.catalina.startup.HostConfig deployDescriptor
AVVERTENZA: A docBase E:\Applicativi\spago\apache-tomcat-7.0.25\webapps\SpagoBIProject inside the host appBase has been specified, and will be ignored
24-gen-2012 15.43.07 org.apache.catalina.startup.SetContextPropertiesRule begin
AVVERTENZA: [SetContextPropertiesRule]{Context} Setting property 'source' to 'org.eclipse.jst.j2ee.server:SpagoBIProject' did not find a matching property.
24-gen-2012 15.43.08 org.apache.catalina.startup.TaglibUriRule body
INFO: TLD skipped. URI: http://java.sun.com/portlet is already defined
24-gen-2012 15.43.08 org.apache.catalina.session.PersistentManagerBase startInternal
GRAVE: No Store configured, persistence disabled
24-gen-2012 15.43.17 org.apache.catalina.startup.HostConfig deployDescriptor
INFO: Deploying configuration descriptor E:\Applicativi\spago\apache-tomcat-7.0.25\conf\Catalina\localhost\SpagoBIAccessibilityEngine.xml
24-gen-2012 15.43.17 org.apache.catalina.startup.HostConfig deployDescriptor
AVVERTENZA: A docBase E:\Applicativi\spago\apache-tomcat-7.0.25\webapps\SpagoBIAccessibilityEngine inside the host appBase has been specified, and will be ignored
24-gen-2012 15.43.17 org.apache.catalina.session.PersistentManagerBase startInternal
GRAVE: No Store configured, persistence disabled
24-gen-2012 15.43.17 org.apache.catalina.startup.HostConfig deployDescriptor
INFO: Deploying configuration descriptor E:\Applicativi\spago\apache-tomcat-7.0.25\conf\Catalina\localhost\SpagoBIBirtReportEngine.xml
24-gen-2012 15.43.17 org.apache.catalina.startup.HostConfig deployDescriptor
AVVERTENZA: A docBase E:\Applicativi\spago\apache-tomcat-7.0.25\webapps\SpagoBIBirtReportEngine inside the host appBase has been specified, and will be ignored
24-gen-2012 15.43.18 org.apache.catalina.startup.TaglibUriRule body
INFO: TLD skipped. URI: http://www.eclipse.org/birt/taglibs/birt.tld is already defined
24-gen-2012 15.43.21 org.apache.catalina.session.PersistentManagerBase startInternal
GRAVE: No Store configured, persistence disabled
24-gen-2012 15.43.21 org.apache.catalina.startup.HostConfig deployDescriptor
INFO: Deploying configuration descriptor E:\Applicativi\spago\apache-tomcat-7.0.25\conf\Catalina\localhost\SpagoBICommonJEngine.xml
24-gen-2012 15.43.21 org.apache.catalina.startup.HostConfig deployDescriptor
AVVERTENZA: A docBase E:\Applicativi\spago\apache-tomcat-7.0.25\webapps\SpagoBICommonJEngine inside the host appBase has been specified, and will be ignored
24-gen-2012 15.43.22 org.apache.catalina.session.PersistentManagerBase startInternal
GRAVE: No Store configured, persistence disabled
24-gen-2012 15.43.22 org.apache.catalina.startup.HostConfig deployDescriptor
INFO: Deploying configuration descriptor E:\Applicativi\spago\apache-tomcat-7.0.25\conf\Catalina\localhost\SpagoBIConsoleEngine.xml
24-gen-2012 15.43.22 org.apache.catalina.startup.HostConfig deployDescriptor
AVVERTENZA: A docBase E:\Applicativi\spago\apache-tomcat-7.0.25\webapps\SpagoBIConsoleEngine inside the host appBase has been specified, and will be ignored
24-gen-2012 15.43.22 org.apache.catalina.session.PersistentManagerBase startInternal
GRAVE: No Store configured, persistence disabled
24-gen-2012 15.43.23 org.apache.catalina.startup.HostConfig deployDescriptor
INFO: Deploying configuration descriptor E:\Applicativi\spago\apache-tomcat-7.0.25\conf\Catalina\localhost\SpagoBIJasperReportEngine.xml
24-gen-2012 15.43.23 org.apache.catalina.core.StandardContext setPath
AVVERTENZA: A context path must either be an empty string or start with a '/'. The path [SpagoBIJasperReportEngine] does not meet these criteria and has been changed to [/SpagoBIJasperReportEngine]
24-gen-2012 15.43.23 org.apache.catalina.startup.HostConfig deployDescriptor
AVVERTENZA: A docBase E:\Applicativi\spago\apache-tomcat-7.0.25\webapps\SpagoBIJasperReportEngine inside the host appBase has been specified, and will be ignored
24-gen-2012 15.43.23 org.apache.catalina.session.PersistentManagerBase startInternal
GRAVE: No Store configured, persistence disabled
24-gen-2012 15.43.24 org.apache.catalina.startup.HostConfig deployDescriptor
INFO: Deploying configuration descriptor E:\Applicativi\spago\apache-tomcat-7.0.25\conf\Catalina\localhost\SpagoBIQbeEngine.xml
24-gen-2012 15.43.24 org.apache.catalina.startup.HostConfig deployDescriptor
AVVERTENZA: A docBase E:\Applicativi\spago\apache-tomcat-7.0.25\webapps\SpagoBIQbeEngine inside the host appBase has been specified, and will be ignored
24-gen-2012 15.43.24 org.apache.catalina.session.PersistentManagerBase startInternal
GRAVE: No Store configured, persistence disabled
24-gen-2012 15.43.24 org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory E:\Applicativi\spago\apache-tomcat-7.0.25\webapps\docs
24-gen-2012 15.43.24 org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory E:\Applicativi\spago\apache-tomcat-7.0.25\webapps\examples
24-gen-2012 15.43.25 org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory E:\Applicativi\spago\apache-tomcat-7.0.25\webapps\host-manager
24-gen-2012 15.43.25 org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory E:\Applicativi\spago\apache-tomcat-7.0.25\webapps\manager
24-gen-2012 15.43.25 org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory E:\Applicativi\spago\apache-tomcat-7.0.25\webapps\ROOT
24-gen-2012 15.43.25 org.apache.coyote.AbstractProtocol start
INFO: Starting ProtocolHandler ["http-apr-8081"]
24-gen-2012 15.43.25 org.apache.coyote.AbstractProtocol start
INFO: Starting ProtocolHandler ["ajp-apr-8010"]
24-gen-2012 15.43.25 org.apache.catalina.startup.Catalina start
INFO: Server startup in 18188 ms


this is SpagoBI.log:

[pool-2-thread-1] 24 gen 2012 15:43:13,582 ERROR it.eng.spagobi.commons.SingletonConfigCache.<init>:36 - The table sbi_config is EMPTY
[pool-2-thread-1] 24 gen 2012 15:43:13,582 ERROR it.eng.spagobi.commons.SingletonConfigCache.get:53 - The property 'SPAGOBI.DATE-FORMAT-SERVER.format' doens't have any value assigned, check SBI_CONFIG table
[pool-2-thread-1] 24 gen 2012 15:43:13,582 ERROR it.eng.spagobi.commons.SingletonConfigCache.get:53 - The property 'SPAGOBI.TIMESTAMP-FORMAT.format' doens't have any value assigned, check SBI_CONFIG table
[pool-2-thread-1] 24 gen 2012 15:43:14,566 ERROR org.hibernate.util.XMLHelper.error:89 - Error parsing XML: jbpm.hibernate.cfg.xml(10) The content of elements must consist of well-formed character data or markup.
[pool-2-thread-1] 24 gen 2012 15:43:14,566 ERROR org.hibernate.util.XMLHelper.error:89 - Error parsing XML: jbpm.hibernate.cfg.xml(10) The content of elements must consist of well-formed character data or markup.
[pool-2-thread-1] 24 gen 2012 15:43:14,582 ERROR org.hibernate.util.XMLHelper.error:89 - Error parsing XML: jbpm.hibernate.cfg.xml(10) The content of elements must consist of well-formed character data or markup.
[pool-2-thread-1] 24 gen 2012 15:43:14,582 ERROR org.hibernate.util.XMLHelper.error:89 - Error parsing XML: jbpm.hibernate.cfg.xml(10) The content of elements must consist of well-formed character data or markup.
[pool-2-thread-1] 24 gen 2012 15:43:16,644 ERROR it.eng.spagobi.commons.initializers.metadata.MetadataInitializer.init:163 - Error while initializing metadata
org.hibernate.PropertyValueException: not-null property references a null or transient value: it.eng.spagobi.engines.config.metadata.SbiEngines.biobjType
at org.hibernate.engine.Nullability.checkNullability(Nullability.java:100)
at org.hibernate.event.def.AbstractSaveEventListener.performSaveOrReplicate(AbstractSaveEventListener.java:312)
at org.hibernate.event.def.AbstractSaveEventListener.performSave(AbstractSaveEventListener.java:203)
at org.hibernate.event.def.AbstractSaveEventListener.saveWithGeneratedId(AbstractSaveEventListener.java:143)
at org.hibernate.event.def.DefaultSaveOrUpdateEventListener.saveWithGeneratedOrRequestedId(DefaultSaveOrUpdateEventListener.java:210)
at org.hibernate.event.def.DefaultSaveEventListener.saveWithGeneratedOrRequestedId(DefaultSaveEventListener.java:56)
at org.hibernate.event.def.DefaultSaveOrUpdateEventListener.entityIsTransient(DefaultSaveOrUpdateEventListener.java:195)
at org.hibernate.event.def.DefaultSaveEventListener.performSaveOrUpdate(DefaultSaveEventListener.java:50)
at org.hibernate.event.def.DefaultSaveOrUpdateEventListener.onSaveOrUpdate(DefaultSaveOrUpdateEventListener.java:93)
at org.hibernate.impl.SessionImpl.fireSave(SessionImpl.java:713)
at org.hibernate.impl.SessionImpl.save(SessionImpl.java:701)
at org.hibernate.impl.SessionImpl.save(SessionImpl.java:697)
at it.eng.spagobi.commons.initializers.metadata.MetadataInitializer.writeEngines(MetadataInitializer.java:385)
at it.eng.spagobi.commons.initializers.metadata.MetadataInitializer.init(MetadataInitializer.java:79)
at it.eng.spago.init.InitializerManager.init(InitializerManager.java:79)
at it.eng.spago.configuration.ConfigServlet.init(ConfigServlet.java:115)
at org.apache.catalina.core.StandardWrapper.initServlet(StandardWrapper.java:1266)
at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1185)
at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:1080)
at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:5015)
at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5302)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:897)
at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:873)
at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:615)
at org.apache.catalina.startup.HostConfig.deployDescriptor(HostConfig.java:649)
at org.apache.catalina.startup.HostConfig$DeployDescriptor.run(HostConfig.java:1581)
at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
at java.util.concurrent.FutureTask.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
[pool-2-thread-1] 24 gen 2012 15:43:16,660 ERROR it.eng.spagobi.commons.SingletonConfigCache.get:53 - The property 'SPAGOBI.SECURITY.PORTAL-SECURITY-INIT-CLASS.className' doens't have any value assigned, check SBI_CONFIG table
[pool-2-thread-1] 24 gen 2012 15:43:16,723 ERROR it.eng.spagobi.analiticalmodel.functionalitytree.dao.LowFunctionalityDAOHibImpl.insertLowFunctionality:647 - The Domain with value_cd=LOW_FUNCT does not exist.
[pool-2-thread-1] 24 gen 2012 15:43:16,754 ERROR it.eng.spagobi.analiticalmodel.functionalitytree.init.TreeInitializer.initialize:108 - EMFUserError
it.eng.spago.error.EMFUserError: severity [ERROR] description [Error while inserting the functionality]
at it.eng.spagobi.analiticalmodel.functionalitytree.dao.LowFunctionalityDAOHibImpl.insertLowFunctionality(LowFunctionalityDAOHibImpl.java:64
at it.eng.spagobi.analiticalmodel.functionalitytree.init.TreeInitializer.initialize(TreeInitializer.java:104)
at it.eng.spagobi.analiticalmodel.functionalitytree.init.TreeInitializer.init(TreeInitializer.java:53)
at it.eng.spago.init.InitializerManager.init(InitializerManager.java:79)
at it.eng.spago.configuration.ConfigServlet.init(ConfigServlet.java:115)
at org.apache.catalina.core.StandardWrapper.initServlet(StandardWrapper.java:1266)
at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1185)
at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:1080)
at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:5015)
at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5302)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:897)
at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:873)
at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:615)
at org.apache.catalina.startup.HostConfig.deployDescriptor(HostConfig.java:649)
at org.apache.catalina.startup.HostConfig$DeployDescriptor.run(HostConfig.java:1581)
at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
at java.util.concurrent.FutureTask.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
[pool-2-thread-1] 24 gen 2012 15:43:16,754 ERROR it.eng.spagobi.commons.SingletonConfigCache.get:53 - The property 'INDEX_INITIALIZATION.jndiResourcePath' doens't have any value assigned, check SBI_CONFIG table
[pool-2-thread-1] 24 gen 2012 15:43:16,754 ERROR it.eng.spagobi.commons.utilities.SpagoBIUtilities.readJndiResource:257 - java.lang.NullPointerException
[pool-2-thread-1] 24 gen 2012 15:43:16,754 ERROR it.eng.spagobi.commons.SingletonConfigCache.get:53 - The property 'INDEX_INITIALIZATION.name' doens't have any value assigned, check SBI_CONFIG table
[http-apr-8081-exec-2] 24 gen 2012 15:43:53,941 ERROR it.eng.spagobi.commons.SingletonConfigCache.get:53 - The property 'SPAGOBI.SPAGOBI-MODE.mode' doens't have any value assigned, check SBI_CONFIG table
[http-apr-8081-exec-2] 24 gen 2012 15:43:53,941 ERROR it.eng.spagobi.commons.utilities.ChannelUtilities.getSpagoBIContextName:115 - SPAGOBI.SPAGOBI-MODE.mode IS NULL
[http-apr-8081-exec-3] 24 gen 2012 15:43:53,972 ERROR it.eng.spagobi.commons.SingletonConfigCache.get:53 - The property 'SPAGOBI_SSO.INTEGRATION_CLASS_JNDI' doens't have any value assigned, check SBI_CONFIG table
[http-apr-8081-exec-3] 24 gen 2012 15:43:53,988 ERROR it.eng.spagobi.commons.utilities.SpagoBIUtilities.readJndiResource:257 - java.lang.NullPointerException
[http-apr-8081-exec-3] 24 gen 2012 15:43:53,988 ERROR it.eng.spagobi.services.common.SsoServiceFactory.createProxyService:55 - Error occurred
java.lang.NullPointerException
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Unknown Source)
at it.eng.spagobi.services.common.SsoServiceFactory.createProxyService(SsoServiceFactory.java:52)
at it.eng.spagobi.commons.filters.ProfileFilter.findUserId(ProfileFilter.java:135)
at it.eng.spagobi.commons.filters.ProfileFilter.doFilter(ProfileFilter.java:74)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
at it.eng.spagobi.commons.filters.SpagoBICoreCheckSessionFilter.doFilter(SpagoBICoreCheckSessionFilter.java:86)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:224)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:169)
at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:472)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:16
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:9
at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:927)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:11
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:407)
at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:987)
at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:579)
at org.apache.tomcat.util.net.AprEndpoint$SocketProcessor.run(AprEndpoint.java:1805)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
[http-apr-8081-exec-3] 24 gen 2012 15:43:53,988 ERROR it.eng.spagobi.commons.filters.ProfileFilter.doFilter:104 - java.lang.NullPointerException
[http-apr-8081-exec-3] 24 gen 2012 15:43:54,097 ERROR it.eng.spagobi.commons.SingletonConfigCache.get:53 - The property 'SPAGOBI_SSO.ACTIVE' doens't have any value assigned, check SBI_CONFIG table
[http-apr-8081-exec-3] 24 gen 2012 15:43:54,097 ERROR it.eng.spagobi.commons.SingletonConfigCache.get:53 - The property 'SPAGOBI.LANGUAGE_SUPPORTED.LANGUAGE.default' doens't have any value assigned, check SBI_CONFIG table
[http-apr-8081-exec-3] 24 gen 2012 15:43:54,113 ERROR it.eng.spagobi.commons.SingletonConfigCache.get:53 - The property 'SPAGOBI.LANGUAGE_SUPPORTED.LANGUAGES' doens't have any value assigned, check SBI_CONFIG table
[http-apr-8081-exec-3] 24 gen 2012 15:43:54,113 ERROR it.eng.spagobi.commons.utilities.GeneralUtilities.getSupportedLocales:498 - NO LOCALES CONFIGURED!!!


these are war deployed:
SpagoBI
SpagoBIAccessibilityEngine
SpagoBIBirtReportEngine
SpagoBICommonJEngine
SpagoBIConsoleEngine
SpagoBIJasperReportEngine
SpagoBIQbeEngine

Added in server.xml in <GlobalNamingResources> section:

<Environment name="spagobi_resource_path" type="java.lang.String" value="../resources"/>
<Environment name="spagobi_sso_class" type="java.lang.String" value="it.eng.spagobi.services.common.FakeSsoService"/>
<Environment name="spagobi_service_url" type="java.lang.String" value="http://*********:8081/SpagoBI"/>
<Environment name="spagobi_host_url" type="java.lang.String" value="http://*********:8081"/>

<Resource name="jdbc/spagobi" auth="Container"
type="javax.sql.DataSource"
driverClassName="com.microsoft.sqlserver.jdbc.SQLServerDriver"
url="jdbc:sqlserver://host9:1433;databaseName=*******"
username="******"
password="******"
maxActive="20"
maxIdle="10"
maxWait="-1" />

<Resource auth="Container" factory="de.myfoo.commonj.work.FooWorkManagerFactory" maxThreads="5" name="wm/SpagoWorkManager" type="commonj.work.WorkManager"/>



Context.xml: no modified.

for each server I added .xml in conf/Catalina/localhost with this contents:

<Context docBase="SpagoBIProject" path="/SpagoBI" privileged="true" reloadable="true" source="org.eclipse.jst.j2ee.server:SpagoBIProject">
<Manager className="org.apache.catalina.session.PersistentManager" saveOnRestart="false"/>
<ResourceLink global="jdbc/spagobi" name="jdbc/spagobi" type="javax.sql.DataSource"/>
<ResourceLink global="spagobi_resource_path" name="spagobi_resource_path" type="java.lang.String"/>
<ResourceLink global="spagobi_sso_class" name="spagobi_sso_class" type="java.lang.String"/>
<ResourceLink global="spagobi_host_url" name="spagobi_host_url" type="java.lang.String"/>
<!--ResourceLink global="spagobi_domain" name="spagobi_domain" type="java.lang.String"/-->
</Context>


webapps/SpagoBI/WEB-INF/classes/hibernate.cfg.xml:

<session-factory name="HibernateSessionFactoryMySQL">
<property name="hibernate.connection.datasource">java:/comp/env/jdbc/spagobi</property>
<property name="hibernate.dialect">org.hibernate.dialect.SQLServerDialect</property>
<!--
<property name="hibernate.dialect">org.hibernate.dialect.MySQLDialect</property>
<property name="hibernate.dialect">org.hibernate.dialect.SQLServerDialect</property>
<property name="hibernate.dialect">org.hibernate.dialect.PostgreSQLDialect</property>
<property name="hibernate.dialect">org.hibernate.dialect.Oracle9Dialect</property>
<property name="hibernate.dialect">org.hibernate.dialect.IngresDialect</property>
<property name="hibernate.dialect">org.hibernate.dialect.HSQLDialect</property>
<property name="hibernate.dialect">org.hibernate.dialect.DB2400Dialect</property>
-->
.....
.....


webapps/SpagoBI/WEB-INF/classes/jbpm.hibernate.cfg.xml:

< property name="hibernate.dialect">org.hibernate.dialect.SQLServerDialect</property>
<!-- jdbc connection properties -->
<!-- property name="hibernate.dialect">org.hibernate.dialect.HSQLDialect</property-->
<!--property name="hibernate.dialect">org.hibernate.dialect.MySQLDialect</property-->
<!-- property name="hibernate.dialect">org.hibernate.dialect.IngresDialect</property-->
<!-- property name="hibernate.dialect">org.hibernate.dialect.SQLServerDialect</property-->
...
...


webapps/SpagoBI/WEB-INF/classes/quartz.properties:

# Default Properties file for use by StdSchedulerFactory
# to create a Quartz Scheduler Instance, if a different
# properties file is not explicitly specified.
#
org.quartz.scheduler.instanceName = DefaultQuartzScheduler
org.quartz.scheduler.rmi.export = false
org.quartz.scheduler.rmi.proxy = false
org.quartz.scheduler.wrapJobExecutionInUserTransaction = false
org.quartz.threadPool.class = org.quartz.simpl.SimpleThreadPool
org.quartz.threadPool.threadCount = 10
org.quartz.threadPool.threadPriority = 5
org.quartz.threadPool.threadsInheritContextClassLoaderOfInitializingThread = true
org.quartz.jobStore.misfireThreshold = 60000
#-------------- START JOB STORE --------------------------------------------
#org.quartz.jobStore.class = org.quartz.simpl.RAMJobStore
org.quartz.jobStore.class = org.quartz.impl.jdbcjobstore.JobStoreTX
org.quartz.dataSource.quartz.jndiURL=java:comp/env/jdbc/spagobi
#org.quartz.dataSource.quartz.driver = org.postgresql.Driver
#org.quartz.dataSource.quartz.URL = jdbc:postgresql://localhost:5432/quartz
#org.quartz.dataSource.quartz.user = postgres
#org.quartz.dataSource.quartz.password = postgres
#org.quartz.dataSource.quartz.maxConnections = 5
#-------------- job store delegate class -----------------------------------
# Hsqldb delegate class
#org.quartz.jobStore.driverDelegateClass=org.quartz.impl.jdbcjobstore.HSQLDBDelegate
# Mysql/Ingres delegate class
#org.quartz.jobStore.driverDelegateClass=org.quartz.impl.jdbcjobstore.StdJDBCDelegate
# Postgres delegate class
#org.quartz.jobStore.driverDelegateClass=org.quartz.impl.jdbcjobstore.PostgreSQLDelegate
# Oracle delegate class
#org.quartz.jobStore.driverDelegateClass=org.quartz.impl.jdbcjobstore.oracle.OracleDelegate
# SQLServer delegate class
org.quartz.jobStore.driverDelegateClass=org.quartz.impl.jdbcjobstore.MSSQLDelegate
#---------------------------------------------------------------------------
org.quartz.jobStore.dataSource =quartz
#-------------- END JOB STORE ----------------------------------------------


what's wrong?
thank's in advance

This message was edited 1 time. Last update was at 27/01/2012 14:53:09

angioia

SpagoBI hero
[Avatar]

Joined: 12/04/2010 15:41:11
Messages: 562
Location: Milan, Italy
Offline

That's a known bug:https://www.spagoworld.org/jira/browse/SPAGOBI-712" target="_new" rel="nofollow"> https://www.spagoworld.org/jira/browse/SPAGOBI-712

We are sorry for the inconvenience.

Regards,
AG

Andrea Gioia
-------------------------
@andrea_gioia
@geobinitiative
-------------------------
[WWW]
gorotman.spw

Newby

Joined: 10/01/2012 12:17:21
Messages: 21
Offline

It works..........now repository isn't empty and server starts correctly.

Thank's a lot, angioia!
Bye

This message was edited 2 times. Last update was at 27/01/2012 14:08:21

shyju.spw



Joined: 30/04/2012 08:46:22
Messages: 3
Offline

the spagobi 3.4 all in one server also gives the same message
SEVERE No STore configured , persistence disabled.

Kindly give a solution
[Email]
juanmsosa.spw

Newby

Joined: 15/06/2012 16:23:08
Messages: 22
Offline

shyju.spw wrote:the spagobi 3.4 all in one server also gives the same message
SEVERE No STore configured , persistence disabled.

Kindly give a solution


Hi everyone, i have same problem and search in the forum for hours but dont find answer. Please help

Thanks in advance
juanmsosa.spw

Newby

Joined: 15/06/2012 16:23:08
Messages: 22
Offline

juanmsosa.spw wrote:
shyju.spw wrote:the spagobi 3.4 all in one server also gives the same message
SEVERE No STore configured , persistence disabled.

Kindly give a solution


Hi everyone, i have same problem and search in the forum for hours but dont find answer. Please help

Thanks in advance



after 2 days of search i found 1 post where taking about this problem => https://www.spagoworld.org/jforum/posts/list/1278.page#4304


hope this help.
systems.spw



Joined: 15/12/2013 12:46:28
Messages: 1
Offline

I have the same problem with Version 4.1 and the patch does not work. Why not simply provide the actual demo data formatted for MySQL and avoid the empty db configuration issue? Why provide demo data only for HSQLDB?
 
Forum Index » Technical Help - SpagoBI Server - CORE
Go to:   
Powered by JForum 2.1.9 © JForum Team