[Logo] SpagoWorld Forums
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing  
[Groups] Back to home page  [Moderation Log] Moderation Log   [Register] Register /  [Login] Login 
intall spagoBI win7  XML
Forum Index » Technical Help - SpagoBI Server - CORE
Author Message
hihei.spw



Joined: 14/05/2012 10:23:35
Messages: 3
Offline

aghedin wrote:Hi,
thank you for your suggestions, we are updating our wiki..
But don’t worry this month we are going to release SpagoBI book and it is updated at the version 3.4 of SpagoBI and SpagoBI Studio 3.4.

You cant’ see any log because the web application is not running yet..

Act in this way:

1) Open the folder (installation folder of SpagoBIServer)/database
2) Run start.bat (in this way you are starting up the HSQLDB)
3) Open the folder (installation folder of SpagoBIServer)/bin
4) Run startup.bat (in this way you are starting up tomcat)

I hope this helps you


I did it . . . But http://localhost:8080/SpagoBI doesnt work . . . any suggestion??
aghedin

SpagoBI hero
[Avatar]

Joined: 14/07/2010 09:25:00
Messages: 465
Offline

Hi,
can you describe your system:
What is your operative system?
What is the version of your jdk?
How do you install SpagoBI (have you used the Installer or have you downloaded the All-In-One-SpagoBI-3.4?)
Have you change the configurations (for example the db connections)?

Alberto Ghedin

~~~ sis felix ~~~
hihei.spw



Joined: 14/05/2012 10:23:35
Messages: 3
Offline

Windows 7 64bit
JDK: Java SE Development Kit 7u4 [the last version]
I've download "InstallerSpagoBI-3.4_04162012.zip" in http://forge.ow2.org/project/showfiles.php?group_id=204&release_id=4905

I didn't change any confugurations . . .
hihei.spw



Joined: 14/05/2012 10:23:35
Messages: 3
Offline

Ok, the problem was that I didn't create enviroment varible JAVA_HOME . . . Now the problem is "Grave: No Store configured, persistence disabled", I'll try to resolve it.
glyn.astill.spw



Joined: 03/05/2012 11:24:33
Messages: 6
Offline

Versions below, I just extracted the zip file and ran as instructed.

SpagoBIStudio_3.4_win_04162012
jdk1.7.0_04

I've not been impressed with the contact I've had direct from Spago World with regards to our business getting support for SpagoBI. Whith this in mind I'm abandoning any further investigation into this product for the time being.
aghedin

SpagoBI hero
[Avatar]

Joined: 14/07/2010 09:25:00
Messages: 465
Offline

hihei.spw wrote:Ok, the problem was that I didn't create enviroment varible JAVA_HOME . . . Now the problem is "Grave: No Store configured, persistence disabled", I'll try to resolve it.


Don’t worry about that error, it’s “normal” in the sense that it should refers on the persistence of the session with the tomcat and SpagoBI doesn’t use it.
Is SpagoBI up?

Alberto Ghedin

~~~ sis felix ~~~
bambam.spw



Joined: 13/05/2012 06:37:57
Messages: 5
Offline

I followed the instructions in this link http://wiki.spagobi.org/xwiki/bin/view/spagobi_server/Installation_v3#HInstallJDK

1. I first installed JDK 1.6. To check whether successfully installed, I query the version thru C:\java -version and it says
java version "1.6.0_12"
Java <™> SE Runtime Environment <build 1.6.0_12-b04>

2. I downloaded and installed Tomcat 6.0.18

3. Download and installed mySQL server including workbench. Created database foodmart, run mysql-create.sql and MySQL-create-quartz-schema.sql using mySQL Workbench. I also created SpagoBI database (don't know why :)

4. Copied the war files and put it in tomcat webapps folder. Run tomcat exe.

5. Edited server.xml file located in Tomcat 6.0\conf folder to reflect data source and environment variables including thread manager.

6. Created folder spagoBI2.0\resources in C:\

7. Copied the needed libraries to tomcat 6.0\lib

8. Run localhost:8080/SpagoBI and got that error message.


Thanks!
aghedin

SpagoBI hero
[Avatar]

Joined: 14/07/2010 09:25:00
Messages: 465
Offline

Hi,
check the folder apache-tomcat-6.0.x/conf/ and, if exists, remove the folder Catalina with the contexts of SpagoBI webaps.

This message was edited 2 times. Last update was at 14/05/2012 16:22:14


Alberto Ghedin

~~~ sis felix ~~~
bambam.spw



Joined: 13/05/2012 06:37:57
Messages: 5
Offline

Thanks for the response.

I checked Tomcat's conf folder and there are only 2 catalina files i saw. the catalina.policy and the catalina.properties. I am not seeing the catalina folder.

I tried removing the two files and transfer it in a new folder inside tomcat, but still got the same error. I checked the command messages when SpagoBIStartup.bat is running and i saw something like JRE_HOME is not present. Just wondering where to set this since it's not in the instruction.

I tried the AllinOne installer in another computer and run the SpagoBIStartup.bat as instructed but when i checked http://localhost:8080, it's not running. so i decided to take the step by step procedure.


thanks!

aghedin

SpagoBI hero
[Avatar]

Joined: 14/07/2010 09:25:00
Messages: 465
Offline

Ok try to act in this way:
1) Open the folder (installation folder of SpagoBIServer)/database
2) Edit the file start.bat in this way java -cp ./hsqldb1_8_0_2.jar org.hsqldb.Server -database.0 ./foodmart -dbname.0 foodmart -Xmx256m
3) Open the folder (installation folder of SpagoBIServer)/bin
4) Run SpagoBIStratup.bat

This message was edited 2 times. Last update was at 14/05/2012 16:21:48


Alberto Ghedin

~~~ sis felix ~~~
aghedin

SpagoBI hero
[Avatar]

Joined: 14/07/2010 09:25:00
Messages: 465
Offline

bambam.spw wrote:Thanks for the response.

I tried removing the two files and transfer it in a new folder inside tomcat, but still got the same error. I checked the command messages when SpagoBIStartup.bat is running and i saw something like JRE_HOME is not present. Just wondering where to set this since it's not in the instruction.




The JRE_HOME is the home directory of the installation of Java.
You’ve installed the JDK 1.6.x, so you should have a directory with a path similar to this one C:\Programs\Java\jdk 1.6.0_12
In the system variables you should have a something like JAVA_HOME = C:\Programs\Java\jdk 1.6.0_12. If you don’t have it create It.

Alberto Ghedin

~~~ sis felix ~~~
bambam.spw



Joined: 13/05/2012 06:37:57
Messages: 5
Offline

thanks aghedin. i tried setting the environment variable. this time, no problem seen in the command window. so i tried reloading http://localhost:8080/SpagoBI but i got the same error below.. what does it mean by <%@page import="it.eng.spagobi.commons.utilities.ChannelUtilities"%>

and also jasper thing is so visible in the error message.

what could be the possible reasons?


thank you once again.
evamay

===============
type Exception report

message

description The server encountered an internal error () that prevented it from fulfilling this request.

exception

org.apache.jasper.JasperException: Unable to compile class for JSP:

An error occurred at line: 6 in the generated java file
Only a type can be imported. it.eng.spagobi.commons.utilities.ChannelUtilities resolves to a package

An error occurred at line: 8 in the generated java file
it.eng.spago.dispatching.httpchannel.AbstractHttpJspPagePortlet cannot be resolved to a type

An error occurred at line: 23 in the generated java file
The method getServletConfig() is undefined for the type index_jsp

An error occurred at line: 24 in the generated java file
The method getServletConfig() is undefined for the type index_jsp

An error occurred at line: 45 in the generated java file
The method getPageContext(Servlet, ServletRequest, ServletResponse, String, boolean, int, boolean) in the type JspFactory is not applicable for the arguments (index_jsp, HttpServletRequest, HttpServletResponse, null, boolean, int, boolean)

An error occurred at line: 28 in the jsp file: /SpagoBI/index.jsp
ChannelUtilities cannot be resolved
25: %>
26: <%@page import="it.eng.spagobi.commons.utilities.ChannelUtilities"%>
27: <%
28: String contextName = ChannelUtilities.getSpagoBIContextName(request);
29: String redirectURL = contextName + "/servlet/AdapterHTTP?PAGE=LoginPage&NEW_SESSION=TRUE";
30: response.sendRedirect(redirectURL);
31: %>


Stacktrace:
org.apache.jasper.compiler.DefaultErrorHandler.javacError(DefaultErrorHandler.java:92)
org.apache.jasper.compiler.ErrorDispatcher.javacError(ErrorDispatcher.java:330)
org.apache.jasper.compiler.JDTCompiler.generateClass(JDTCompiler.java:423)
org.apache.jasper.compiler.Compiler.compile(Compiler.java:317)
org.apache.jasper.compiler.Compiler.compile(Compiler.java:295)
org.apache.jasper.compiler.Compiler.compile(Compiler.java:282)
org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:586)
org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:317)
org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:342)
org.apache.jasper.servlet.JspServlet.service(JspServlet.java:267)
javax.servlet.http.HttpServlet.service(HttpServlet.java:717)


note The full stack trace of the root cause is available in the Apache Tomcat/6.0.18 logs.
aghedin

SpagoBI hero
[Avatar]

Joined: 14/07/2010 09:25:00
Messages: 465
Offline

Hi,
do you have this problem in the installation that uses your db (mysql) or the hsqldb (the default one) ?

If you have the problem the default db try to act in this way:

1) Open the folder (installation folder of SpagoBIServer)/database
2) Edit the file start.bat in this way java -cp ./hsqldb1_8_0_2.jar org.hsqldb.Server -database.0 ./foodmart -dbname.0 foodmart -Xmx256m
3) Open the folder (installation folder of SpagoBIServer)/bin
4) Run SpagoBIStratup.bat

This message was edited 1 time. Last update was at 14/05/2012 16:27:59


Alberto Ghedin

~~~ sis felix ~~~
bambam.spw



Joined: 13/05/2012 06:37:57
Messages: 5
Offline

Thanks aghadin.

I tried using the AllInOne again with the JAVA_HOME defined in the system variables this time. And it works! Will start exploring now!


Thanks. See u in my other future posts.


evamay
tariq.spw



Joined: 30/06/2014 12:01:26
Messages: 2
Offline

Hello Good People,
I'm also having problems installing SpagoBI on Win7.
STATUS:
> I have installed SpagoBI 4.2 All in One (C:\SpagoBI-dir);
> Spago Meta; Spago Studio;Open Office;
> My OS is win7 32bit
> I have also installed Java 7.0
> I have set the variable env for JAVA_HOME; CATALINA_HOME; OPENOFFICE_HOME;
> I can open HSQLDB in the command window via SpagoBI.bat

ISSUE:

> When I try and access "http://localohost:8080/SpagoBI" I get "This page cannot be displayed"
"The remote device or resource won't accept the connection Detected Detected
The device or resource (localhost) is not set up to accept connections on port 8080."

> Also I'm not able to open "Tom Cat" via startUp.bat (the Command window flashes for a moment then disappears)


I have researched every where for solutions and now finally I'm reaching out to the Spago Community for help.

If you can respond at your earliest convenience it would be of immense help.

Thank you
Tariq
 
Forum Index » Technical Help - SpagoBI Server - CORE
Go to:   
Powered by JForum 2.1.9 © JForum Team