[Logo] SpagoWorld Forums
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing  
[Groups] Back to home page  [Moderation Log] Moderation Log   [Register] Register /  [Login] Login 
Chart optional Y Series grouping  XML
Forum Index » Technical Help - SpagoBI Server - REPORTING
Author Message
freekb.spw

SpagoBI supporter

Joined: 08/07/2010 09:46:26
Messages: 152
Offline

Hi,

I try to make a Birt Stacked Chart .

Where the series contain a value (number sold), the Optional Y Series Grouping, contain the product names, and the Category X Series contain the month-year.

In SpagoStudio it fails with the message 'Mismatch (3!=1) in dataset count found in stacked runtime series'.

If I remove the field product names from the Optional Y Series Grouping it works. But... it does no show what I would like to see...

Anybody any clue?

Thanks in advance,
Freek
arod.spw

Newby

Joined: 06/07/2010 21:54:53
Messages: 26
Location: México
Offline

Hi freekb, not sure exactly when your problem start showing. I have some reports that trigger that error when I run it
in SBI-BRE 2.7 (which has BIRT 2.6), but runs ok in SBI-BRE 2.6 (with BIRT 2.5.2) and I'm almost sure your problem is
related to this bug: https://bugs.eclipse.org/bugs/show_bug.cgi?id=321599.

I just update my Eclipse-BIRT to 2.6.1, an the graph with the mismatch x!=y error is running again.

So, or stay with SBI 2.6 or update the birt engine in SBI-BRE 2.7 (sorry I don't have the steps to do it)
freekb.spw

SpagoBI supporter

Joined: 08/07/2010 09:46:26
Messages: 152
Offline

Hi Arod,

Thanks for that, I think that you are right indeed. I hope that the SpagoBI team is reading these posts and decide to update Birt to the newest version in the next release. It's a topic for me since this type of report can not be made by Jasper Reports as far as I could see.

By the way I hope they update the Jasper engine as well since it includes several features that makes live nicer as well.

Best regards,
Freek
hiperusera.spw

Newby

Joined: 30/12/2010 17:50:13
Messages: 37
Offline

Hi Arod, if you updated birt in spagobi studio to 2.6.1 also updated engine birt in
SpagoBI Server 2.7, how do you do this?
Thanks
 
Forum Index » Technical Help - SpagoBI Server - REPORTING
Go to:   
Powered by JForum 2.1.9 © JForum Team