[Logo] SpagoWorld Forums
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing  
[Groups] Back to home page  [Moderation Log] Moderation Log   [Register] Register /  [Login] Login 
Several problems with migrating SpagoBI 2.7-2.8 to 3.0 with MySQL and tomcat  XML
Forum Index » Technical Help - SpagoBI Server - CORE
Author Message
freekb.spw

SpagoBI supporter

Joined: 08/07/2010 09:46:26
Messages: 152
Offline

Hi,

I've tried to migrate from SpagoBI 2.7 via 2.8 to 3.0 and I run into the following problems.

1) The migration script for MySQL from 2.8 to 3.0 does not create the SBI_CONFIG table correctly. You need to copy the create table statement from the MySQL_CREATE.sql file.

2) The passwords were stored in the past as not-encrypted. In 3.0 they seem to be encrypted, so I had to remove the biadmin user and startup tomcat again, which created the biadmin user as default. After that I could login as biadmin.

3) I hoped to edit the other userid's, but the bug, reported before in 2.8, where the error in the SpagoBI.log file appears with 'Caused by: com.mysql.jdbc.exceptions.MySQLSyntaxErrorException: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '5 sbiuser0_.ID as ID72_, sbiuser0_.USER
_IN as USER2_72_, sbiuser0_.USER_UP as US' at line 1', is still there. Clearly the 5 is in the way, a comma should be before the sbiuser0_.ID statement. The same is by the way the case for the roles management.

4) The bug, reported before, that a Jasperreport in a composite document is very often not showing up is still there. (in a composite document with 7 jasperreports every other refresh there is a document disappearing).

Point 3 and 4 make this version unusable, point 2 makes the migration a bit harder, is there a way to automatically encrypt the current passwords or should I do it manually after the conversion took place?

Thanks in advance,
Freek
drari.spw

Newby

Joined: 19/11/2010 11:34:25
Messages: 48
Offline

Hi Freekb,

what I heard from the presentation meeting we had in Paris last tuesday 21th June,
is that they will upload in the coming days a corrected version of the files available on the repository of OW2.

I hope it will solve most of those issues, so let's keep an eye on it

regards
Hakim
freekb.spw

SpagoBI supporter

Joined: 08/07/2010 09:46:26
Messages: 152
Offline

Hi Hakim,

Thanks for the reply. I'm looking forward to it. I would love to use the new Jasperreport engine, but the same problems appear in 2.8 as well, so I hope they solve it all.

Best regards,
Freek
rapidoss.spw

Newby

Joined: 05/07/2011 14:07:08
Messages: 47
Offline

hi all,
i have a problem to import from 2.8 to 3.0 .

this is the erro in log file:


Error while importing association between exported function with path [/Functionalities/Financing] and exported role with name [Model_Admin]

hope someone can help me ,

thnx
freekb.spw

SpagoBI supporter

Joined: 08/07/2010 09:46:26
Messages: 152
Offline

Hi,

Is there any plan for when these changes will happen.

Thanks in advance,
Freek
scamuzzo

SpagoBI friend
[Avatar]

Joined: 17/12/2010 17:57:48
Messages: 50
Offline

To manage the password encryption, if you are migrating users from a 2.8 to 3.0 you can follow this procedure if you can not access as biadmin:

1) in the table SBI_CONFIG take the row "internal.security.encript.password" and change the value of the column VALUE_CHECK from "true" to "false". A SQL statement like "update sbi_config set value_check = 'false' where LABEL = 'internal.security.encript. password (here it's easier to use the ID column, check for the correct value, typically it is 1

2) connect to SpagoBI with the biadmin user

3) go to the Tools-Manage Configurations and set back the value to true (now you can do it and don't need to manually change the table in the DB !)

4) reassign passwords to all users and test back

Remember also to set the correct dialect, this could be the reason for your #3 issue. As an example if you are using spagobi metadata on MySql the value of the dialect in the spagobi Data Source and in the webapps/SpagoBI/WEB-INF/classes/hibernate.cfg.xml file should be set to "MySQLDialect"

Regards

Stefano Scamuzzo

Stefano Scamuzzo
SpagoWorld
freekb.spw

SpagoBI supporter

Joined: 08/07/2010 09:46:26
Messages: 152
Offline

Thanks Stefano,

Freek
omehacker.spw

Newby

Joined: 12/10/2017 13:46:24
Messages: 11
Offline

This is the kind of video game Platform am looking for.When i first visit this website homepage play online fireboy and watergirl am shocked to know that here i can play even without Download or register.It's Magic for me,and now i love to play here by using my special skills.Thank you.
 
Forum Index » Technical Help - SpagoBI Server - CORE
Go to:   
Powered by JForum 2.1.9 © JForum Team