[Logo] SpagoWorld Forums
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing  
[Groups] Back to home page  [Moderation Log] Moderation Log   [Register] Register /  [Login] Login 
Messages posted by: scamuzzo
Forum Index » Profile for scamuzzo » Messages posted by scamuzzo
Author Message
Please send an email to spagobi@eng.it, the SpagoBI mailing list for all commercial questions. You will be contacted by a member of the commercial team.
Kind regards
Stefano Scamuzzo
SpagoBI Labs
This error may appear if you are missing the following line in your server.xml file:

<Realm className="org.apache.catalina.realm.UserDatabaseRealm" resourceName="UserDatabase"/>

Please check
Regards
If spagobi metadata are hosted on HSQL, as it is the case for the All-In-One package, ensure you are using the SpagoBIStartup.bat file and not the startup.bat one
MySql is not mandatory to host SpagoBI metadata. You can also use PosgreSQL, Oracle or Sql Server.
Scripts are available together with the software distribution
Dancap, please mark the thread as [SOLVED]

Thanks
Verify the dialect in your SpagoBI data source definition

regards
I have never been in touch with the book's authors and I don't know them. In the upcoming months a book by SpagoBI team will be available for purchase. Forums wikis and tutorials are already a good source of information, everyone who needs more can have a look to the SpagoBI services.

Hope this helps you.

Thank you and best regards

Stefano Scamuzzo
SpagoBI International Manager
The most appropriate solution to your requirement is to configure Single Sign On and to implement a Java connector to retrieve user values from your existing security environment. Find more info on SpagoBI wiki.

Thanks
Geoffrey, the bug 623 is closed

Please open a Jira bug for the errors on Oracle scripts

Thanks a lot

stefano
There's a case issue in the script creating the MySql tables.

Probably you have the table hibernate_sequences in capital letters.

Open your mysql client and issue a command like

RENAME TABLE `SpagoBI`.`HIBERNATE_SEQUENCES` TO `SpagoBI`.`hibernate_sequences` ;

then restart SpagoBI.

stefano
Anything in the SpagoBI.log file ?

tx

Hi Saurya

you should define the resource in the server.xml file under the conf directory of Tomcat

You should add lines like the following, adapt the values to your installation:


<Resource name="jdbc/mydb" auth="Container"
type="javax.sql.DataSource" driverClassName="com.mysql.jdbc.Driver"
url="jdbc:mysql://localhost/mydb"
username="root" password="mysql" maxActive="20" maxIdle="10"
maxWait="-1"/>

Then add a line in all context.xml file in the SpagoBI webapps you are using (under META-INF folder):

<ResourceLink global="jdbc/mydb" name="jdbc/mydb" type="javax.sql.DataSource"/>

Regards

Stefano Scamuzzo
To manage the password encryption, if you are migrating users from a 2.8 to 3.0 you can follow this procedure if you can not access as biadmin:

1) in the table SBI_CONFIG take the row "internal.security.encript.password" and change the value of the column VALUE_CHECK from "true" to "false". A SQL statement like "update sbi_config set value_check = 'false' where LABEL = 'internal.security.encript. password (here it's easier to use the ID column, check for the correct value, typically it is 1

2) connect to SpagoBI with the biadmin user

3) go to the Tools-Manage Configurations and set back the value to true (now you can do it and don't need to manually change the table in the DB !)

4) reassign passwords to all users and test back

Remember also to set the correct dialect, this could be the reason for your #3 issue. As an example if you are using spagobi metadata on MySql the value of the dialect in the spagobi Data Source and in the webapps/SpagoBI/WEB-INF/classes/hibernate.cfg.xml file should be set to "MySQLDialect"

Regards

Stefano Scamuzzo
Please

send the contents of the SBI_EXPORTERS, SBI_ENGINES and SBI_DOMAINS tables

Concerning the empty columns in Excel, are you getting the same problem even form BIRT itself or only when executing the report in SpagoBI?

Regards

The demo is using HyperSonic database (HSQL).

Details on how to change the database are available in the SpagoBI wiki

https://wiki.spagobi.org/xwiki/bin/view/Main/

Regards

Stefano
 
Forum Index » Profile for scamuzzo » Messages posted by scamuzzo
Go to:   
Powered by JForum 2.1.9 © JForum Team