[Logo] SpagoWorld Forums
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing  
[Groups] Back to home page  [Moderation Log] Moderation Log   [Register] Register /  [Login] Login 
Messages posted by: nishant.bahikar.spw.spw
Forum Index » Profile for nishant.bahikar.spw.spw » Messages posted by nishant.bahikar.spw.spw
Author Message
Hello all,

Was going through the same issue then later found out that problem was that
multivalue was passed as a sing varchar string along with comma.

so i modified my dataset and it worked

Older dataset -
[
select * from tablename where column in (?)
]
-- a, b

New dataset -
[

select * from tablename where column in
(select
regexp_split_to_table
(
( select replace ( (?::varchar),'"','') as a ), E',') as C )

]

-- ?::varchar -- it should be of type varchar
-- replace " with blank as when we select radio button or list it adds up " by itself ( not required for manual input parameter )
-- split values in multiple rows seperated by ,
-- mydatbase was postgres

Thanks ,
Nishant Bahikar


Hello all,

Was going through the same issue then later found out that problem was that
multivalue was passed as a sing varchar string along with comma.

so i modified my dataset and it worked

Older dataset -
[
select * from tablename where column in (?)
]
-- a, b

New dataset -
[

select * from tablename where column in
(select
regexp_split_to_table
(
( select replace ( (?::varchar),'"','') as a ), E',') as C )

]

-- ?::varchar -- it should be of type varchar
-- replace " with blank as when we select radio button or list it adds up " by itself ( not required for manual input parameter )
-- split values in multiple rows seperated by ,
-- mydatbase was postgres

Thanks ,
Nishant Bahikar


Hello all,

Was going through the same issue then later found out that problem was that
multivalue was passed as a sing varchar string along with comma.

so i modified my dataset and it worked

Older dataset -
[
select * from tablename where column in (?)
]
-- a, b

New dataset -
[

select * from tablename where column in
(select
regexp_split_to_table
(
( select replace ( (?::varchar),'"','') as a ), E',') as C )

]

-- ?::varchar -- it should be of type varchar
-- replace " with blank as when we select radio button or list it adds up " by itself ( not required for manual input parameter )
-- split values in multiple rows seperated by ,
-- mydatbase was postgres

Thanks ,
Nishant Bahikar


Hello all,

Was going through the same issue then later found out that problem was that
multivalue was passed as a sing varchar string along with comma.

so i modified my dataset and it worked

Older dataset -
[
select * from tablename where column in (?)
]
-- a, b

New dataset -
[

select * from tablename where column in
(select
regexp_split_to_table
(
( select replace ( (?::varchar),'"','') as a ), E',') as C )

]

-- ?::varchar -- it should be of type varchar
-- replace " with blank as when we select radio button or list it adds up " by itself ( not required for manual input parameter )
-- split values in multiple rows seperated by ,
-- mydatbase was postgres

Thanks ,
Nishant Bahikar


 
Forum Index » Profile for nishant.bahikar.spw.spw » Messages posted by nishant.bahikar.spw.spw
Go to:   
Powered by JForum 2.1.9 © JForum Team