[Logo] SpagoWorld Forums
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing  
[Groups] Back to home page  [Moderation Log] Moderation Log   [Register] Register /  [Login] Login 
Messages posted by: hahmed.spw
Forum Index » Profile for hahmed.spw » Messages posted by hahmed.spw
Author Message
Is it possible to combine data from multiple QbE queries using something like a UNION operator? I have a few tables without any relationship with same column count and data types and would like to show them all in a single worksheet.
SpagoBI 5.2 download link is broken and returns the following error
The requested URL /spagobi/All-In-One-SpagoBI-5.2.0_08042016.zip was not found on this server.
You can use http://www.digitalvolcano.co.uk/content/textcrawler/tcdownload for the first step. The rest of the steps are same.
Add the following in web.xml (found in WEB-INF folder in SpagoBI, SpagoBIJasperReportEngine and other Report engines)



and also add to the same file

Somehow SpagoBI can not find the jar file. You should only have sqljdbc4.jar in lib folder.
You have the SQL JDBC .jar file in tomcat/lib folder?

Can you check logs/SpagoBI.log and logs/catalina.out for any errors?
Please check logs/SpagoBIJasperReports.log for any errors and post here.
http://en.wikipedia.org/wiki/Hibernate_%28Java%29
If you can see Arabic-Indic Numbers in your report tool (iReport/BIRT) then they would appear the same way in SpagoBI.
You don't need to define GlobalNamingResoruce in server.xml to add a datasource so first of all you can remove that.

Secondly your JDBC URL should be: jdbc:sqlserver://[SERVERNAME OR IP];instanceName=sqlexpress;databaseName=AdventureWorks

It should work after that.
Hello,

Only 64-bit Java should be enough, you will need to set JAVA_HOME or add java folder to path.

Also try running from the command prompt to see what error you're getting.
Shutdown Tomcat

1. Download Squirrel SQL
2. Right click at HSQLDB Stand-alone click modify driver, then goto extra class path and add the driver jar for it (use the hsqldb jar in spagobi/lib folder) and close
3. Goto Aliases tab and add new Alias, select HSQLDB Standalone and enter the following URL jdbc:hsqldb:FULL_PATH_TO_YOUR_SPAGOBI_FOLDER/database/spagobi
4. Set the username to sa and password blank
5. Connect, and goto PUBLIC->TABLE->SBI_USER and find the ID of biadmin (its 7 in 3.1 by default)
6. Goto SBI_EXT_ROLES and find the ID of /spagobi/admin role (its 3)
7. Goto SBI_EXT_USER_ROLES and add a row with ID of biadmin and EXT_ROLE_ID of /spagobi/admin role

Start SpagoBI
I can confirm that SpagoBI 3.1 with the new oracle dbscripts is working fine. If its your new installation why not go with 3.1
My experience with 3.0 showed that the Oracle script generates errors, also the data initialization also doesn't work with Oracle DB (probably due to dbscript errors or data type incompatibilities)

I don't think this has been fixed in 3.1. Your best option would be to install MySQL db alongside oracle for SBI data and add Oracle DB as Datasource for reports (which works absolutely fine).
My experience with 3.0 showed that the Oracle script generates errors, also the data initialization also doesn't work with Oracle DB (probably due to dbscript errors or data type incompatibilities)

I don't think this has been fixed in 3.1. Your best option would be to install MySQL db alongside oracle for SBI data and add Oracle DB as Datasource for reports (which works absolutely fine).
 
Forum Index » Profile for hahmed.spw » Messages posted by hahmed.spw
Go to:   
Powered by JForum 2.1.9 © JForum Team