[Logo] SpagoWorld Forums
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing  
[Groups] Back to home page  [Moderation Log] Moderation Log   [Register] Register /  [Login] Login 
Messages posted by: micmen.spw
Forum Index » Profile for micmen.spw » Messages posted by micmen.spw
Author Message
Hi, I have created a multicube schema for my application to permit profiled data on a custom defined profile attribute.
I have a cube containing this code:
<Dimension name="MEDICO_D" foreignKey="CODICE_FISCALE_MEDICO">
<Hierarchy name="Medico" hasAll="true" allMemberName="Tutti i medici" allMemberCaption="Tutti i medici" primaryKey="CODICE_FISCALE">
<View alias="Medico">
<SQL dialect="generic">
select codice_fiscale as codice_fiscale, nominativo as nominativo
from dim_medico
where codice_fiscale like '${filter}'
</SQL>
</View>
<Level name="NOMINATIVO_L" column="CODICE_FISCALE" nameColumn="CODICE_FISCALE" visible="false" type="String" uniqueMembers="false" levelType="Regular" hideMemberIf="Never" captionColumn="NOMINATIVO">
</Level>
</Hierarchy>
</Dimension>
If I login as Admin (filter = %), I see all data with chance to choose a particular member of MEDICO_D.
If I login as UserMedico (filter = "value of codice fiscale"), I see always all data and moreover when I go in MDX query wizard and select a particular member, system loop on "Loading" screen (without click on Submit button, only on radiobutton selection).
Thanks for response,
Michele.
Thanks, I apply this "patch" and now run well.

Regards,
Michele.
Hi, in my application I have defined a schema.xml containing 3 cube definition, one for each user category. To filter data on a custom profile attribute "userid" I define a Dimension as follow :



The problem is that when I login as Admin (the profile attribute "userid" is null or not corrisponding to user in table dim_medico) and query return empty resultset, an error occurs when I try to run or modify a query using this cube.
Thanks,
Michele.
 
Forum Index » Profile for micmen.spw » Messages posted by micmen.spw
Go to:   
Powered by JForum 2.1.9 © JForum Team