[Logo] SpagoWorld Forums
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing  
[Groups] Back to home page  [Moderation Log] Moderation Log   [Register] Register /  [Login] Login 
Messages posted by: zsoltputnoky.spw
Forum Index » Profile for zsoltputnoky.spw » Messages posted by zsoltputnoky.spw
Author Message
Hi Community,

Have an issue with alignment of labels in a grid within a birt report. I specify vertical alignment for each label in each cell, when I preview the report in Spago Studio or in SpagoBI, all labels are arriving on the top of the cell. Also checked the XML of the report and it looks okay.

Have a look on the images to see what I mean:



and this is how it comes:



Any idea?

Cheers,

Zsolt
Yeah, it is a crazy stuff. I dont understand the reason. Hope they will be able to fix it as it is forcing me to use a solution which is not the preferred one: creating views in a production DB and querying directly the view. Not what I really want to do.
Let's see when the devs will respond.

Zsolt
Dataset: depends on how you did the report. Since I have to hack something together, I define the dataset in the report with BIRT, then when I am deploying, I only specify the datasource available on the server.

To deploy a data source - as far as I know - you need to create a Business Model, then a query on top of the model, then you can deploy the query as data set to Spago.

Hope it help,

Zsolt
Hi Community,

I try to create a report which displays some HTML text in one of the column (using DynamicText), this text can be longer than the available place. I would like the field/row to grow to display the content. I tried playing with Overflow, but no success.

See the image below:



How this can be fixed?

Zsolt
I dont know. I use 3.6 and it happened. Once I applied the patch the issue was gone. Started to play with Spago recently, so cant say how other versions behave.

Zsolt
d.synchronized@gmail.com.spw wrote:i got the same porblem with filters ,u found any solution..do reply..
thanks


Hi There,

Have a look here: https://spagobi.eng.it/jira/browse/SPAGOBI-994

I believe it fixed my problem. See the readme file in the ZIP to see what to do with it.

Good luck,

Zsolt
Hi Alberto,

Do you have any ideas how to fix it? I will experiment with this stuff, but need a definitive solution.

Zsolt
Hi Community,

I developed several reports and deployed them on the server. Before I do so, I check it in Spago Studio. Noticed that the report does not look the same in Spago Studio and on the Server.

1) How the report looks in the Studio




2) How the report looks on the Server



It looks like that some formats are lost during the deployment.

Do you have any ideas how to solve it?

Cheers,

Zsolt

macortel wrote:This is the first time I see this problem. I see that you are using a path name "SpagoBITest - Local", try to use a path name without the "-" symbol (I'm not sure but this could be a problem for the serialization process) and see if there are any differences.
Thank you.

Regards,
Marco


Ciao Marco,

I tried with a project named with 3 letters, the result is the same. I think I will be able to do my project (mock-up) with this issue.

Zsolt
Ok Marco, I will do that tomorrow morning and let you know. I learned to live with this issue till you fix it and proceeded with the project.

Ciao,

Zsolt
Hi Marco,

Here is the picture book.















Zsolt


:) tell me how can I post a screenshot and I will do it
There is no filter condition, I just select one field, put it as filter, save, crash, remove, save, hurrahhh, works
I posted the error message few post before
See the mail above, it is only enabled when I add a filter condition, but then it is crashing (see 2 mails before), if I remove the filter condition, it is enabled
Ciao Marco,

Here is the crazy thing:

- Create model -->ok
- Create a query
--> select the fileds --> no way to save
--> add a filter --> meta 3.6 is crashing with the error posted above
--> remove the filter --> I AM ABLE TO SAVE THE QUERY :)
--> close the query builder
--> reopen the query --> IT WORKS!

Zsolt
Marco,

I tried to use Meta 3.6, same settings as before, but this time I got an error message:

16:24:16.497 [main] DEBUG i.e.q.datasource.AbstractDataSource - i18n properties loaded form cache

!ENTRY org.eclipse.ui 4 4 2012-12-12 16:24:16.506
!MESSAGE Save Failed

!ENTRY org.eclipse.ui 2 0 2012-12-12 16:24:16.508
!MESSAGE Save Failed
!STACK 0
java.lang.RuntimeException: Impossible to save query
at it.eng.spagobi.meta.querybuilder.query.dao.QueryDAOFileImpl.getContentToSave(QueryDAOFileImpl.java:85)
at it.eng.spagobi.meta.querybuilder.ui.editor.SpagoBIDataSetEditor.doSave(SpagoBIDataSetEditor.java:324)
at org.eclipse.ui.internal.SaveableHelper$2.run(SaveableHelper.java:151)
at org.eclipse.ui.internal.SaveableHelper$5.run(SaveableHelper.java:277)
at org.eclipse.jface.operation.ModalContext.runInCurrentThread(ModalContext.java:464)
at org.eclipse.jface.operation.ModalContext.run(ModalContext.java:372)
at org.eclipse.jface.window.ApplicationWindow$1.run(ApplicationWindow.java:759)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
at org.eclipse.jface.window.ApplicationWindow.run(ApplicationWindow.java:756)
at org.eclipse.ui.internal.WorkbenchWindow.run(WorkbenchWindow.java:2606)
at org.eclipse.ui.internal.SaveableHelper.runProgressMonitorOperation(SaveableHelper.java:285)
at org.eclipse.ui.internal.SaveableHelper.runProgressMonitorOperation(SaveableHelper.java:264)
at org.eclipse.ui.internal.SaveableHelper.savePart(SaveableHelper.java:156)
at org.eclipse.ui.internal.EditorManager.savePart(EditorManager.java:1369)
at org.eclipse.ui.internal.WorkbenchPage.savePart(WorkbenchPage.java:3334)
at org.eclipse.ui.internal.WorkbenchPage.saveEditor(WorkbenchPage.java:3347)
at org.eclipse.ui.internal.SaveAction.run(SaveAction.java:76)
at org.eclipse.jface.action.Action.runWithEvent(Action.java:49
at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:584)
at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:501)
at org.eclipse.jface.action.ActionContributionItem$6.handleEvent(ActionContributionItem.java:452)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1053)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4066)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3657)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2640)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2604)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:243
at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:671)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:664)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:115)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:620)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:575)
at org.eclipse.equinox.launcher.Main.run(Main.java:140
Caused by: it.eng.qbe.serializer.SerializationException: An error occurred while serializing object: it.eng.qbe.query.Query@187a6dd
at it.eng.qbe.query.serializer.json.QueryJSONSerializer.serialize(QueryJSONSerializer.java:9
at it.eng.spagobi.meta.querybuilder.query.dao.QueryDAOFileImpl.getContentToSave(QueryDAOFileImpl.java:82)
... 44 more
Caused by: java.lang.NullPointerException
at it.eng.qbe.query.serializer.json.QueryJSONSerializer.serializeFilters(QueryJSONSerializer.java:466)
at it.eng.qbe.query.serializer.json.QueryJSONSerializer.serialize(QueryJSONSerializer.java:6
... 45 more
 
Forum Index » Profile for zsoltputnoky.spw » Messages posted by zsoltputnoky.spw
Go to:   
Powered by JForum 2.1.9 © JForum Team